2

Sometimes, when accessing the Meta site, a user ends up in a redirect loop. This is because the Meta site link uses HTTP, while HTTPS is really needed. This bug should really be fixed, as it's keeping people out of Meta.

3
  • 1
    HTTPS is not yet supported anywhere on the Stack Exchange network (aside from login pages and such). Please use the HTTP versions instead. (If you want, you can use HTTPS, but it's not fully supported.) – Doorknob Dec 10 '14 at 3:55
  • @Doorknob冰 The main site supports HTTPS... – Kaz Wolfe Dec 10 '14 at 4:54
  • Meta gives a certificate error – Vogel612 Dec 10 '14 at 7:42
3

While HTTPS connections should work on the main sites, we don't officially support them across the board yet. There are a few roadblocks in place and SSL support is on our list, but it's taking a while to get there.

As far as child metas go, we don't have the certificates for them, so SSL is not supported in any way at all. Unfortunately, short of getting a separate certificate for each child meta, we don't have a lot of options there right now. From Nick's post linked above:

So what about all of our *.stackexchange.com domains? A wildcart cert, excellent we’re knocking these out like crazy. What about meta.*.stackexchange.com? Damn. Can’t do that. You can’t have a wildcard of that form – at least not one supported by most major browsers, which means effectively it’s not an option.

If you're running HTTPS Everywhere or a similar browser addon, please turn it off/set up exceptions for our meta sites. If you see an HTTPS link from one of our sites to a child meta, please let us know so we can fix it to run over HTTP until we're able to flip the SSL switch on network-wide.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .